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A macro is a tool that allows you to save a string of commands (like inserting a file into a comment) into 1- or 

2-keystrokes, enabling instructors to provide a great deal of feedback with a short characters A macro system for 

grading allows you to create rich feedback files for a series of common issues, and then with a few short keystrokes, 

call that whole file into a comment you have inserted into a paper. 

Macros increase efficiency, save time, raise your quality of life during the semester, and give students more 

information and feedback about their work, among other benefits.  My focus here is on using macros as a tool for 

grading student writing, and on the ways that the overall quality of feedback can be enhanced while avoiding the rote 

application of grading rubrics. 

A ”pre-technology” analog might be the numbered “rubric” some teachers used…they would distribute a sheet 

telling you what each number meant that was marked on your paper.  With technology, we can easily skip the number 

and just insert the entire feedback point very quickly. 

How easy is it to set up macros?  Pretty simple, since the two hardest parts are 1) constructing the comments 

and 2) keeping track of the location of the macros and comments (macros are now usually stored by Word in the 

Normal template for your documents, but can also be associated with a single document only if desired). 

 

Why Use Macros? 

 

*More consistent feedback. Handwriting and energy diminish over time grading a stack of papers, so comments are 

sometimes inconsistent (some developed, some short) or illegible. Using a macro to call a file into a comment provides 

the same consistent feedback over time in readable text. 

 

*Stop wasting time.  Writing the same comments over and over is a substantial waste of time, and frankly many 

students make the same mistakes over and over, so why rewrite the same comment 50 times a semester? 

 

*Provide examples and rich resources.  Normally writing comments on papers there is little incentive to include 

URLs, textbook page number references, and other specific resource information.  Macros make this quick and easy. 

 

*Focus on important stuff.  Instead of spending a large portion of grading time correcting and commenting on 

recurring student errors, use macros for these common issues and focus grading time on argument quality and 

conceptual development. 

 

*Adapt on the fly.  Once you run a macro to call a file into a comment, it drops you at the end of the comment so you 

can type more of a specific application to the paper, delete a portion of the comment that doesn’t apply, and adapt the 

more general comment into something that is tied to the student’s topic. 

 

*Help clarify issues in your own mind.  A very real subsidiary benefit to creating rich feedback files is that it requires 

the instructor to identify resources, provide a clear example or two, and articulate how they want to approach the issue 

with students.  For me, this was helpful for my grading consistency even without the time savings. 

 

 

How Do I Start? 

 

In general:  1) Create a series of feedback files in a folder that will always stay in the same location, 2) create a series 

of macros using the Macro tool, and 3) create an easy reference for which keystrokes call which files. 

 

Create Feedback Files 

1)  After grading a stack of papers, go back through and jot down the ten (or so) most common comments you have 

written on papers.  Make choices about which comments could use developing in some depth and are frequent enough 

to justify using a macro. 

 

2)  Take each comment you have selected and type it up into a developed paragraph using MS Word (other word 

processors also have this feature, but here I will only focus on Word).  Apart from the direct comment you might just 

write in the margins of a paper, you can also include other information:  References to readings with page numbers, 



examples, or other resources. Save these files in a consistent location. I name the file starting with the two letter code I 

set below to call the macro.  See example comment, Appendix 1. 

 

Create Macros to Call Files into Comments 

3)  Once you open a new Word file, you can record a macro by selecting View > Macros > Record a Macro.   

Naming:  Name your macro using short two-letter codes or names that are easy and quick to type. See Appendix 2.   

Location:  I store macros in the Normal.dotm, which is the default styles/settings template when you open a new Word 

document.   

 

4)  Select Insert > Object drop down arrow (small white box on full expanded ribbon) > Text from file.  Browse to the 

folder for the files you created and saved above.  Select the file you want and Click OK.  Now position your cursor at 

the end of the comment file  

 

5) Select Macro Stop Recording on the Tools menu (usually a square “stop” button) and you are done. 

 

6) To run a macro while grading an electronic copy of the student paper, select text needing comment and insert 

comment.  While in comment, view macros (Alt-F8, or View > Macros > View Macros), select the one you want to 

insert, click Run. In my use, this is Alt-F8, the two letters, Enter. 
 

7)   For easy access, you can insert “view macros” and “record macros” (and “insert comment”!) buttons in the quick 

tool bar… use the drop-down arrow at the end of the blue quick tool bar above the ribbon… make it display “All 

Commands” instead of “Popular Commands,” then locate the above buttons by title and use the arrow to move them 

onto the tool bar. 

 

Create a Quick Reference Guide 

8) A couple of ideas for tracking the macros…  First, create an abbreviated list separated into clear areas for reference 

while you grade.  Second, open a new file and run every macro in order so you have a complete printout of your macro 

texts. 

 

For hard copy grading, as you grade, mark key words on the papers, and run the appropriate macros to compile a set of 

thoughtful comments to print out and attach to the end of the paper.  Since the macro drops you at the end of the 

general comment you may also add a specific comment at that time. 

 

Issues and Options 

 

1) Losing the “Normal” template due to overwrites and updates.  This erases all of your macros… not a happy feeling.  

Having had this happen once, now when I revise or record a number of macros I make a copy two ways: 

 

-locate your normal.dotm file… Usually in this location where username is your username:   

C:\Users\user name\AppData\Roaming\Microsoft\Templates.   

After you have created a full set of macros, make a copy of the normal.dotm file, maybe normalmacros.dotm?  If the 

normal template is ever overwritten or updated by accident, you will always be able to browse to this location and 

copy and rename the normalmacros.dotm back to the normal.dotm and then restart Word. 

 

-macros are created and edited in something called VBA Editor…  when you edit a macro (View Macros > Edit) you 

are able to actually edit and change the macros (e.g., inserting directory changes… see below), and you can save a 

copy of your macros by going to File > Export and saving the .bas file in a memorable and safe location.  Then it only 

takes a moment to run the VBA Editor and File > Import that file if you lose macros. 

 

2) Losing the folder location so macro returns “cannot locate file.” Sometimes when the macro records your keystrokes 

inserting the file, it doesn’t actually change folder locations so it doesn’t record you entering the macros folder (and 

location).  When this happens, running the macro when Word isn’t already opening from that folder will yield errors.  

Simple fix is to insert the change directory command into all of the macros: 

 

-View macros (Alt-F8, or View > Macros > View Macros), select Edit and enter the VBA Editor, and insert directory 

information into macros that lack the change directory command.  In the image below, macro f0 has a correct change 



directory statement entered, but macro f1 does not.  Simply copy the first f0 change directory statement, move to the 

second f1 macro, insert cursor and enter to create a new line above the selection line and paste.  Then hit the save 

Normal button and you are done. 

 

 

 
 

3) Student paper infrequently reject macros.  There have been occasions when student foreign language settings, 

security settings, and use of other formats (PDF) make it difficult to use macros directly.  In those instances, I use a 

blank open Word document to enter the macros and then copy and paste directly into the PDF comment. 

 

 

There is an investment of time and energy into getting this up and running, and saving copies of the normal.dotm 

template once you have a full set of macros is a good idea to prevent the frustration of losing all the work.  Despite 

these challenges, students greatly appreciate the rich feedback, and I spend more time on their substantive analysis 

than on the smaller details of writing.  Technology can’t solve every problem, but in this instance it has helped my 

grading load and my students get more effective and detailed feedback. 



Appendix 1:  Sample Feedback File on APA References 

 

This is generally what an APA reference looks like (for a newspaper article online): 

Brody, J.E. (2007, December 11).  Mental reserves keep brain agile.  The New York Times.  

http://www.nytimes.com 

 

Note the first name as initial only, the date format and location, lower case title, source provided in italics, 

the retrieved from URL, and the use of Hanging Indent formatting. 

 

This class requires you to use the APA Style Manual (7th edition).  Be sure you use the correct format from 

the style manual, and that you format consistently throughout your paper. There is a great online resource 

available to you about the APA Style:  

https://owl.purdue.edu/owl/research_and_citation/apa_style/apa_style_introduction.html 

http://www.nytimes.com/
https://owl.purdue.edu/owl/research_and_citation/apa_style/apa_style_introduction.html


Appendix 2:  Sample List of Macros Arranged by Area 
 

Comm 300 Macro List, Spring 2020 
 

Methodology 

MC–need canon focus 

MN–canon mixup better structure 

ML–avoid list 

MD–descript, not criticism 

MT–dev. theory 

 

MX–context needs work 

MA–Arg vocabulary 

MM–metaphor theory 

MY–ethos dynamic 

MH–dev. ethos elements 

MP–pathos elements 

MR–arrangement impact 

MF–effects weak 

MS–answer “so what?” 

 

Outline 

OM–too many main points 

OF–outline format 

OL–laundry list subpoints 

OW–no one without a two 

OS–subpoints belong 

OT–titles clear 

OV–outline vs. paper differences 

OD-too many details 

OQ–leave quotes out of outline 

 

Paper Requirements 

PA-Abstract not preview 

PE-Thesis explanation CAFK 

PH–specific R thesis 

PO–outline for paper? 

PS–paper short 

PT–insert paper titles 

 

Quick Encouragement 

KW1-improved 

KW2-gotten better 

KW3-excellent improvement 

KW4-great improvement 

 

Quotation/Citation 

QF–full sentence quotes 

QL–long vs. short quotes 

QT–use varied transitions 

 

QC–proper citations 

QG-using titles for citations 

QP–quote needs page/par 

QM–citations must match references 

QO–overciting 

QB–citations leave out book/article titles 

 

QA–APA for references 

QR–reference all sources 

QD-correct speech reference 

QS–must reference speech 

QI–title, not source first 

QE–make titles lower case 

 

Writing 

TA–awkward writing 

TR–proofread 

 

TC–stream of consciousness 

TF–sentence fragment 

TP–passive voice 

TS–self reference 

TT–tense changes 

TI–It’s vs. its 

 

TU–use e.g.s 

TV–vague assertions 

 

For Revision 

F0-include thesis 

F1–fix outline 

F2–develop context 

F3–put in full paper titles 

F4–get quote and citation format right 

F5–develop elements of ethos 

F6–flesh out argument analysis 

F7–make pathos specific 

F8–beef up effect 

F9–fix references 

G1–draft paper rubric 

 

 


